Project

General

Profile

Feature #1299

Help sonicyang to repair HP 34401A

Added by tin almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/16/2016
Due date:
01/16/2016
% Done:

100%

Estimated time:
6.00 h

Description

Meet sonic at Banciao MRT 1:30pm Jan.16

Meter Has following Issues
  • It's reporting Error 604.
  • DC measurement is extremely inaccurate.
  • Ohm measurement is non-working, but do reports ~ 0ohm if I short the test leads.
  • Conductive Test is Working as excepted.

As I tear it down, measuring the DC supplys, +18V + 15V and 5V, are all good
and Voltage refs, 7.5V, 5V, +-10V, are also good.

IC, Numbering U420, U105, U106, U312, U305, and voltage regulator are all hot as about 40~45 degrees Celsius, as other chips are 33~36 only.

And, I measured U102's resistance.
Everything is on spot except

Pin15 - Pin21 should be 100K measured 69K
Pin29 - Pin30 should be 30K measured 20K
Pin15 - Pin13 should be 100K measured 82K

---
I also had a 34401A with the Error 604 a while back.
This instrument had big problems in the OHMS reading and it turned out to be U201 that fixed it.

- The tantalum cap is well known ( any engineer still using those should be barred of ever designing anything ever again and branded on his forehead with the text 'Tantalum User'. Tantalums are a PEST) I lost the count of how many times i had to fix a machine or instrument and the cause was a fried tantalum. The only good Tantalum is one that is not fitted into anything i own.
- The swithc is also known
- the 2512 resistor ladder next to the front or rear jacks can crack loose in a range of serial numbers
- the cpu on the front panel can explode if tone of the VFD drivers calls it quits and commits harakiri in a fiery fireball.
There is another tantalum in the True RMS section that can kill that one off as well.

Useful threads:

http://www.eevblog.com/forum/testgear/hp-34401a-what-to-worry-about-when-buying-used/msg707008/#msg707008
http://www.eevblog.com/forum/repair/hp-34401a-repair/msg471050/#msg471050
http://www.eevblog.com/forum/repair/hp-34401a-error-604/msg769609/#msg769609
http://www.eevblog.com/forum/repair/agilent-34401a-repair-help-request-%28showing-voltage-without-input%29/msg443134/#msg443134
http://www.eevblog.com/forum/repair/another-34401a-repair-question/msg787984/#msg787984

--

Calibration

1. Zero adjustment 4W short
2. -10V, +500VDC, 10mA@1kHz calibration if A/D , U101 or U505 RAM changed
3. 4W adjustment


Files

34401-90013.pdf (4.16 MB) 34401-90013.pdf tin, 01/13/2016 04:37 AM
Accredited-Calibration-Certificate.pdf (5.02 MB) Accredited-Calibration-Certificate.pdf tin, 01/13/2016 04:56 AM
#2

Updated by tin almost 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Fixed, worklog

Also available in: Atom PDF