Project

General

Profile

Bug #1259

Feature #1238: Repairs

ERROR 114 -- multislope rundown convergence

Added by tin about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
12/10/2015
Due date:
% Done:

100%

Estimated time:

History

#1

Updated by tin about 4 years ago

[quote]Ok, before you replace further components, especially U180, maybe it's possible to test a bit further.

I was under the impression, that the instrument maybe stuck itself into this failure mode, by improper ACAL (?) calibration constants.

Maybe you bring the instrument back to some initial state first.

I assume, that you stored the content of the CAL nvRAM (2kx8).
And you may also have the old DALLAS parts, which you may erase to FF in all cells on your ext. programmer, and then insert into the instrument.
(Store the new nvRAM in a safe place)

Also, please remove these 4x 32kx8 additional RAM, U123-U126, as you used nvRAMs also, which may confuse the instrument on booting.
Maybe, you might also erase the other both 32kx8 nvRAMs to delete all possible stored states.

If you then start the instrument, you will have a virgin state, causing many CAL and ACAL errors.
The FW will initialize all calibration constant to a default, and an initial ACAL will be necessary.
On 2nd boot up, there should be no error any more, provided, the old nvRAMs still work.
(Otherwise you'd have to use the new nvRAMs for that)

Maybe, this may cure the problem.[/quote]

Tried old NVRAMs first thing when saw the error (I did not had new NVRAMs chips by then). I'll try again tonight just to make sure. I had removed additional RAM as well, even removed all ROM chips and checked them to make sure all data verified 100% match to firmware binaries. (I had unit running open cover those two days when it covered, was thinking maybe bit or two got corrupted from sunlight UV. Nope all were 100% match.)

Regarding CAL ROM, I tried that (just poped in old NVRAM chip, which still have original data), no difference.

In case there's no success, you might first measure precisely the +/-12V and +5V ADC references, TP160, 165, 151, for correct ratio (1.69x) relative to LTZ value, and for stability.
(If there's a noteworthy deviation, that may also cause your error).

They were stable up to 5th digit on 2002, also without any spurious large-scale noise measured by scope. I'll measure exact voltages and post later, any data is valuable. I had them on notebook, but did not check ratio to LTZ.

[quote]I'm not sure, if the Time Interpolator is used for normal DCV operation (to my opinion, only in Digitizing Mode, like ACV Sub- and Random Sampled)

But who knows.. Inside there's another EL2018, U405, maybe you check this IC also.[/quote]

Replaced U405 as well, forgot to mention, sorry.

These convergence errors have not yet been understood well in the past (for other instruments).. but this might have to do with the matching of the different slope resistors , as described in hph4/1989, page 12. It's necessary, that the absolute values of these internal resistors fit each other, not extremely precisely, 0.1% only.
They cannot be accessed externally, that's the problem.. But maybe you try carefully to measure the 50k between pin 6 and pin 11/13 of U180, and maybe the minor slope resistors, pins 18,19,21,23.

And you also did not leave any fingerprints there, I assume, which may cause parasitic currents at the A/D.

Cleaned multiple times, IPA, distilled medical grade water, IPA again, no any visible difference.

[quote]Give all that a try before giving up ..[/quote]

Nobody is giving up so easily, just more radical, less enjoyable approach would be taken :)

#2

Updated by tin about 4 years ago

  • Status changed from In Progress to Resolved

Issue fixed by replacement of A3 PCB

#3

Updated by tin about 4 years ago

  • % Done changed from 0 to 100
#4

Updated by tin about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF